summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2025-03-17 03:12:40 +0000
committerxiota2025-03-17 03:12:40 +0000
commitda4f0d20bc669b7e1d1367baaad8edaf90b33c26 (patch)
treefa2933d938c761c6977c1505f599cbdfcfdc7285 /PKGBUILD
parent80636f82033cd9f3167b315ebd86b61fcf79d180 (diff)
downloadaur-localsend.tar.gz
no-error=deprecated-declarations
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf8854f78536..0544140b0892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,10 @@
## options
: ${_install_path:=usr/lib}
-# basic info
_pkgname="localsend"
pkgname="$_pkgname"
pkgver=1.17.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source cross-platform alternative to AirDrop"
url="https://github.com/localsend/localsend"
license=('MIT')
@@ -44,9 +43,11 @@ prepare() {
sed -E 's&^(channel) = .*$&\1 = "stable"&' -i "$_pkgsrc/app/rust-toolchain.toml"
}
-build() {
+build() (
export FVM_CACHE_PATH="$SRCDEST/fvm-cache"
+ export CXXFLAGS+=' -Wno-error=deprecated-declarations'
+
cd "$_pkgsrc/app"
fvm install
@@ -54,7 +55,7 @@ build() {
#fvm flutter pub upgrade --major-versions
fvm flutter --no-version-check pub get
fvm flutter build linux --no-pub --release
-}
+)
package() {
cd "$_pkgsrc/app/build/linux/x64/release/bundle"