summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorApplebloom2016-01-14 04:28:41 +0100
committerApplebloom2016-01-14 04:28:41 +0100
commit9488f2671da08774d4a5adf2da1c54c0dd408551 (patch)
treeb140aea38f1cfd9409fb2944f5d5d18ca4431b45 /PKGBUILD
downloadaur-log4cpp-rc.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dbcecb3e918
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Applebloom <rat.o.drat@gmail.com>
+
+_pkgname="log4cpp"
+pkgname="log4cpp-rc"
+pkgver="1.1.2rc1"
+pkgrel=1
+pkgdesc="A library of C++ classes for flexible logging to files, syslog, IDSA and other destinations. Release candidate version."
+arch=('i686' 'x86_64')
+url="http://log4cpp.sourceforge.net"
+license=('LGPL')
+provides=($_pkgname)
+conflicts=($_pkgname $_pkgname-git)
+source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('1f4c51703fb6cc71379e0a94900577c3')
+
+build() {
+ cd "$_pkgname"
+ ./configure --prefix=/usr --disable-static --disable-doxygen \
+ --disable-dot --without-idsa
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+}