summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFredy García2022-10-03 20:39:08 -0500
committerFredy García2022-10-03 20:39:08 -0500
commita2a712b16348c928927057005843669c5ec88d65 (patch)
tree7d0ebccb0798d0ad480fb778834bd7e81caec77d /PKGBUILD
parent345dd39373b5895437f6dc1a1efcf78d2a578a6b (diff)
downloadaur-m64py.tar.gz
Fix core dump bug by casting integers correctly.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 196d0efdd7a3..3f824a93b979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,28 @@
pkgname=m64py
pkgver=0.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="A Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator"
arch=("any")
url="https://github.com/mupen64plus/mupen64plus-ui-python"
license=("GPL")
depends=("desktop-file-utils" "libxkbcommon-x11" "mupen64plus" "python-pyqt5" "python-pysdl2")
makedepends=("python-distribute")
-source=("https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=("0223569ec031b6e6c1d96ac51a19b9262cccce7705c84b5ca5044c94afb75fca")
+source=(
+ "https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "fix_core_dump_by_int_cast.patch"
+)
+sha256sums=(
+ "0223569ec031b6e6c1d96ac51a19b9262cccce7705c84b5ca5044c94afb75fca"
+ "598672aa8f821a9b28cdeae8a8058661e379460d9f1201104146623dc59ba7c1"
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # https://github.com/mupen64plus/mupen64plus-ui-python/issues/191
+ patch -Np1 -i "${srcdir}/fix_core_dump_by_int_cast.patch"
+}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"