summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStanisław Jasiewicz2022-06-23 21:15:01 +0200
committerStanisław Jasiewicz2022-06-23 21:15:01 +0200
commitafbf1733f86ace56e9d0f407e35387271da66807 (patch)
tree160ade2cf6cbe14b3888db47d953fce9061f84ce /PKGBUILD
parente1073c3be6945a66c2582b7782f9fcdb9bb47891 (diff)
downloadaur-mango.tar.gz
Version 2.0.1
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97f16d0e6209..da07252d6fbc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Stanisław Jasiewicz <stjasiewicz@gmail.com>
+# Maintainer: Stanisław Jasiewicz <stjasiewicz@protonmail.com>
pkgname=mango
-pkgver=1.4.3
+pkgver=2.0.1
pkgrel=1
pkgdesc="A tool for making backups of Arch packages and their dependencies"
arch=('any')
url="https://gitlab.com/Taro94/mango"
license=('GPL')
-depends=('tar')
-makedepends=('dotnet-sdk-3.1')
+depends=('tar' 'pacman')
+makedepends=('dotnet-sdk>=6')
source=("https://gitlab.com/Taro94/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('ca47e93b557b6b4173e54bd585303dae')
+md5sums=('f95a3fc5d28b886ae449ffc06cd21e01')
options=(!strip)
+build() {
+ cd "$pkgname-$pkgver/Mango"
+ dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -p:PublishReadyToRun=true -o published
+ mv published/Mango published/mango
+}
+
package() {
- cd "$pkgname-$pkgver"
- dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -o published
- install -Dm 755 "published/${pkgname}" -t "$pkgdir/usr/bin"
- install -Dm 755 "mango/fakepkg.sh" -t "$pkgdir/usr/share/mango"
+ cd "$pkgname-$pkgver/Mango"
+ ls
+ install -Dm 755 "published/mango" -t "$pkgdir/usr/bin"
+ install -Dm 755 "published/fakepkg.sh" -t "$pkgdir/usr/share/mango"
}