summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManhong Dai2019-01-21 15:32:49 -0500
committerManhong Dai2019-01-21 15:32:49 -0500
commit241be10a21f7cb89aae04e43a17ef7b2dfd05226 (patch)
tree2ba949ebec292466021ed59a41134ea19e1c0ab9 /PKGBUILD
parent4b9c09a3c3a5b079330d7b8afe7b46a3599b33fc (diff)
downloadaur-mgrep-trie.tar.gz
pkgname mgrep -> mgrep-trie
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e31fe03933b7..f77f9c72f9af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Manhong Dai <daimh@umich.edu>
-pkgname=mgrep
+pkgname=mgrep-trie
pkgver=20190121
pkgrel=1
pkgdesc="print lines that match millions of strings efficiently"
@@ -24,13 +24,13 @@ build() {
cd $pkgname
./configure
make
- rm -f man/$pkgname.1.gz
- gzip man/$pkgname.1
+ rm -f man/mgrep.1.gz
+ gzip man/mgrep.1
}
check() {
- $pkgname/src/$pkgname --version
+ $pkgname/src/mgrep --version
}
package() {
- install -Dm755 $pkgname/src/$pkgname "$pkgdir/usr/bin/$pkgname"
- install -Dm644 $pkgname/man/$pkgname.1.gz "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
+ install -Dm755 $pkgname/src/mgrep "$pkgdir/usr/bin/mgrep"
+ install -Dm644 $pkgname/man/mgrep.1.gz "$pkgdir/usr/share/man/man1/mgrep.1.gz"
}