summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2022-09-27 18:47:05 +0200
committerMichel Zou2022-09-27 18:47:05 +0200
commit44e0b44da211c3ad90c1f91e5a75981b198e73a1 (patch)
treee98db39b7552c921d92fec81d597b8db4c0e1e3c /PKGBUILD
parenta56573bef36ff6bbfd1e816cc97e50c38114d9f8 (diff)
downloadaur-mingw-w64-libogg.tar.gz
remove LIBRARY directive
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00fa457264b5..a3043a6acb7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-libogg
pkgver=1.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="Ogg bitstream and framing library (mingw-w64)"
arch=(any)
url="http://xiph.org"
@@ -17,6 +17,11 @@ sha256sums=('c4d91be36fc8e54deae7575241e03f4211eb102afb3fc0775fbbc1b740016705')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
_pkgname="${pkgname#mingw-w64-}"
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ curl -L https://github.com/xiph/ogg/pull/72.patch | patch -p1
+}
+
build() {
for _arch in ${_architectures}; do
${_arch}-cmake -S ${_pkgname}-${pkgver} -B build/${_arch}-static -G Ninja \
@@ -43,4 +48,4 @@ package() {
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done
-} \ No newline at end of file
+}