summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvan Overman2024-03-22 17:23:41 -0700
committerEvan Overman2024-03-22 17:23:41 -0700
commite51a139c84e334d0626677a8c551e089022f02c0 (patch)
tree8490dfe1280db57dccbf83c9079c58e10e89766b /PKGBUILD
parent9ca00f7dec9fc1b9dd9b9c5c77cadb9901529ffd (diff)
downloadaur-miniplayer-git.tar.gz
update install method
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a41d39c14dd..0df5b3d73de9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
pkgname=miniplayer-git
_pkgname=miniplayer
pkgver=1.8.1.r8.gbe25e0c
-pkgrel=2
+pkgrel=3
pkgdesc='A curses based mpd client with basic functionality and album art written for the Kitty terminal.'
url='https://github.com/guardkenzie/miniplayer'
-depends=('python>=3.7' 'python-mpd2' 'pixcat' 'ueberzug' 'python-colorthief')
+depends=('python>=3.7' 'python-mpd2' 'python-pixcat-an-prata-git' 'ueberzug' 'python-colorthief')
makedepends=('git' 'python-setuptools')
provides=('miniplayer')
conflicts=('miniplayer')
@@ -23,12 +23,14 @@ pkgver() {
build(){
cd "${srcdir}/${_pkgname}"
- python setup.py build
+
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}"
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}