summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author5chdn2016-08-25 10:02:41 +0200
committer5chdn2016-08-25 10:02:41 +0200
commit14f0d09c54509cf546c3e9f26a7193eea3a1ff37 (patch)
tree6e0bcecb04aaf4e994efc8559d630e750a00e5af /PKGBUILD
parent5e69d01fbfaab4a968e3a6e5d9b3e18b0cc5767b (diff)
downloadaur-mist-git.tar.gz
Release Beta 0.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a9f402d0f0b..f825ab86480a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=mist-git
_pkgname=mist
-pkgver=0.8.r1.g83b87bf
+pkgver=0.8.2.r6.g18fa764
pkgrel=1
pkgdesc="Mist dapp browser and Ethereum wallet (git version)."
arch=('i686' 'x86_64')
depends=(
'gmp'
+ 'geth'
'leveldb'
'qt5-base'
'qt5-declarative'
@@ -25,21 +26,16 @@ makedepends=(
'gulp'
)
provides=(
- 'geth'
'mist'
'libnode'
)
conflicts=(
- 'geth'
- 'geth-git'
- 'go-ethereum'
- 'go-ethereum-git'
'mist'
'libnode'
'libnode-git'
)
optdepends=(
- 'ethereum: The cpp-ethereum commandline client.'
+ 'parity: The fast, light, robust Ethereum client.'
)
url="https://github.com/ethereum/mist"
license=('GPL')
@@ -70,10 +66,7 @@ build() {
git pull
git submodule update --init
git apply "${srcdir}/mist-pathfix.patch"
- npm install meteor-build-client
- npm install gulp
npm install
- gulp update-nodes
gulp mist --platform linux
}
@@ -93,7 +86,6 @@ package() {
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/${_pkgname}/Mist" "${pkgdir}/usr/bin/mist"
- ln -s "/usr/share/${_pkgname}/resources/node/geth/geth" "${pkgdir}/usr/bin/geth"
install -Dm644 "${pkgdir}/usr/share/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
rm "${pkgdir}/usr/share/${_pkgname}/LICENSE"
@@ -109,5 +101,4 @@ package() {
find "${pkgdir}" -type f -exec chmod 644 {} +
chmod 755 "${pkgdir}/usr/share/${_pkgname}/Mist"
chmod 755 "${pkgdir}/usr/share/${_pkgname}/libnode.so"
- chmod 755 "${pkgdir}/usr/share/${_pkgname}/resources/node/geth/geth"
}