summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas P2023-05-27 02:11:23 +0300
committerLeonidas P2023-05-27 02:11:23 +0300
commit3c6b96c1b06f72ec21aa44005d0eaf5ba3d1fd25 (patch)
tree446183e566a3983b16db4a9aeef823c7791dc26f /PKGBUILD
parent953f35827ad1e5255125032b3a66611da3dfbdb4 (diff)
downloadaur-mmc-utils-git.tar.gz
Upstream fixed. Remove CFLAGS patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e38a4c38bc6..40c7b2a29247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=mmc-utils
pkgname=${_pkgname}-git
-pkgver=r109.145c74a
-pkgrel=1
+pkgver=r113.9582278
+pkgrel=2
epoch=1
pkgdesc="Userspace tools for MMC/SD devices"
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
@@ -13,25 +13,14 @@ license=('GPL')
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=(
- 'git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git'
- 'append-CFLAGS.patch'
-)
-sha256sums=(
- 'SKIP'
- '0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc'
-)
+source=('git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
+sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${_pkgname}"
- patch --forward --strip=1 --input="${srcdir}/append-CFLAGS.patch"
-}
-
build() {
cd "${_pkgname}"
make