summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKuoi2022-08-28 23:03:23 +0100
committerKuoi2022-08-28 23:03:23 +0100
commit0bc1edf245be1dab2d8d10458860b4d41f848908 (patch)
tree42e021dc0d3217daa89458447204628154003090 /PKGBUILD
downloadaur-modeltest-ng-mpi.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a503f9cd104
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi ("malcology") <guoyizhang@malacology.net>
+# Contributor: Guoyi ("malcology") <guoyizhang@malacology.net>
+
+pkgname=modeltest-ng-mpi
+pkgver=0.1.7
+pkgrel=7
+pkgdesc="A New and Scalable Tool for the Selection of DNA and Protein Evolutionary Models. https://doi.org/10.1093/molbev/msz189"
+url='https://github.com/ddarriba/modeltest'
+arch=('x86_64')
+depends=('openmpi')
+makedepends=('bison' 'git' 'cmake' 'make' 'flex')
+license=('GPL3')
+source=("git+https://github.com/ddarriba/modeltest.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+provides=('modeltest-ng')
+conflicts=('modeltest-ng')
+prepare(){
+ cd ${srcdir}/modeltest
+ git submodule update --init --recursive
+}
+build(){
+ cd ${srcdir}/modeltest/
+ mkdir build && cd build
+ cmake -DUSE_MPI=ON ..
+ make
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/bin
+ install -Dm755 "${srcdir}/modeltest/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}