summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera Micó2024-03-10 23:40:50 +0000
committerJoan Bruguera Micó2024-03-10 23:40:50 +0000
commit19aac1cfce9da00f33ea3278fb9f90b0d2955459 (patch)
treebd72960d550d1107bfe76f003e49830b5ddf5092 /PKGBUILD
parent1b7f8ed492178a6dcfde8746fec76130a30a98fa (diff)
downloadaur-nanox.tar.gz
Fix build with GCC 14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32a5c941705e..b83c3f80ab3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _bundlepkgname='ompss'
pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
pkgver='0.15.20190627'
_bundlepkgver='19.06'
-pkgrel='3'
+pkgrel='4'
arch=('x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL2')
@@ -12,16 +12,19 @@ depends=(extrae sqlite3)
makedepends=(python)
source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
"nanox-Fix-build-due-to-Werror-sign-compare-mismatch.patch"
- "nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch")
+ "nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch"
+ "nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch")
sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2
d72f15c858309a5dbed09259e6700220c5b1d931aef9f37c9df0b9ccdf16c22b5d09f4efaab445e944f1a2dee9f5e6c8d96df34bfa765c8c47f6a212f8d168f6
- f900d2c30236ef641e1e527364324e317d1df2746082df0e0bf8adcceb279b7cde6f0c094576e330de24fc9d51f989016f6e2d50489e308fe2f8683acb3bf41c)
+ f900d2c30236ef641e1e527364324e317d1df2746082df0e0bf8adcceb279b7cde6f0c094576e330de24fc9d51f989016f6e2d50489e308fe2f8683acb3bf41c
+ 46a3aebbc723771fdb54e863463321dc0f58a3f95a20b953d767f88a54768bb50f0170139dc9ad0c181be41fa1ba684edc4e15e001553f15649129ec483efccf)
prepare() {
cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-Werror-sign-compare-mismatch.patch"
patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch"
+ patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch"
}
build() {