summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 09:32:47 -0700
committerMark Wagie2024-01-21 09:32:47 -0700
commit58f1e5ce80a8dbc1a926fd74dde099ce1c8f56ec (patch)
tree8a7b3f7fde8cc989c5d539e2bb9f3fe480f6cc26 /PKGBUILD
parent4b00b4129ed4f35251c0467f3d31e7d5972bf7e3 (diff)
downloadaur-nemo-deja-dup-git.tar.gz
correct file permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b23827564e95..8b1a910eafe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=nemo-deja-dup-git
pkgver=r2.f99427f
-pkgrel=4
+pkgrel=5
pkgdesc="Déjà Dup Actions for Nemo File Manager"
arch=('any')
url="https://github.com/erickj/nemo-actions"
-license=('GPL')
+license=('unknown')
depends=('nemo' 'deja-dup')
makedepends=('git')
provides=("${pkgname%-git}")
@@ -14,12 +14,11 @@ source=("git+https://github.com/erickj/nemo-actions.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/nemo-actions"
+ cd nemo-actions
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/nemo-actions"
- install -Dm755 deja-dup_restore-missing.nemo_action -t "$pkgdir/usr/share/nemo/actions"
- install -Dm755 deja-dup_revert.nemo_action -t "$pkgdir/usr/share/nemo/actions"
+ cd nemo-actions
+ install -Dm644 *.nemo_action -t "$pkgdir/usr/share/nemo/actions/"
}