summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefano Probst2015-10-02 09:08:32 +0200
committerStefano Probst2015-10-02 09:08:32 +0200
commitbe3d6e2218965db74cd9379e5bedd4a98ebe884e (patch)
tree89d53440edc7f453b9a916212f220d4f53eaca1c /PKGBUILD
downloadaur-nesc.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58957191ee20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stefand Probst <s1probst@edu.aau.at>
+pkgname="nesc"
+pkgver=1.3.6
+pkgrel=1
+pkgdesc="A extension to the C programming language designed to embody the structuring concepts and execution model of TinyOS."
+arch=('i686' 'x86_64')
+url="https://github.com/tinyos/nesc/"
+license=('GPL2')
+depends=('emacs' 'gperf' 'bison' 'flex' 'java-environment')
+makedepends=('automake' 'autoconf')
+options=('!buildflags')
+source=("https://github.com/tinyos/$pkgname/archive/v$pkgver.zip")
+md5sums=('985866de3e5fd1deb3648db2f1b06566')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./Bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}