summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpetRUShka2015-07-01 17:32:59 +0300
committerpetRUShka2015-07-01 17:32:59 +0300
commit35f7c73feeff9b55be33c92e90a7d292cd663a2a (patch)
tree979f615f46b34fb272ef5a87cf81422ea6bd4a5b /PKGBUILD
downloadaur-newick-utils.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..984bca067028
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=newick-utils
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="The Newick Utilities are a suite of Unix shell tools for processing phylogenetic trees. Functions include re-rooting, extracting subtrees, trimming, pruning, condensing, drawing (ASCII graphics or SVG)."
+arch=('any')
+url="http://cegg.unige.ch/newick_utils"
+license=('BSD')
+groups=()
+depends=('libxml2' )
+makedepends=('automake' 'autoconf')
+optdepends=('guile')
+source=(http://cegg.unige.ch/pub/$pkgname-$pkgver.tar.gz)
+md5sums=('5f65b0fe30bf9389297616358f01fac7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR=$pkgdir
+}