summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2023-06-28 18:35:52 +0200
committerNarrat2023-06-28 18:35:52 +0200
commit6061957cdf6635e2437352f93de5ec537306586d (patch)
tree2f69c1558f6f16f0040fa36c260adc735ec4eb3b /PKGBUILD
parente7709df214351d5e22845ef5171e619fb7ffe6db (diff)
downloadaur-nocache.tar.gz
nocache: update to 1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07e523c5fcdf..6e5f009b5e3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
-# Maintainer: <grawity@gmail.com>
+# Contributor: <grawity@gmail.com>
# Contributor: goll <adrian.goll+aur[at]gmail>
pkgname=nocache
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="minimize caching effects"
arch=(i686 x86_64)
url="https://github.com/Feh/nocache"
license=('FreeBSD License')
-_commit=e4e77a48528739188dccbdbd8b4d2d2d49aa0d99
-source=("git+https://github.com/Feh/nocache.git#commit=$_commit")
-sha256sums=('SKIP')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Feh/nocache/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('2f8c6adbc82da4477416e1eaf9d435cf52f602d07064602f433d4ba4ecad5fdd')
-pkgver() {
- cd "$pkgname"
- git describe | sed "s/^v//; s/-/.r/; s/-/./"
-}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir" install
}