summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-02-21 09:30:23 +0100
committerJulien Nicoulaud2019-02-21 09:30:23 +0100
commitb5aaa73d25af60edaab55830e0be2ebd62d9b3f3 (patch)
tree5f6a1fc4db49c42afca40e437faa45c6a9fadc30 /PKGBUILD
downloadaur-nutty.tar.gz
1.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07cceb2da58e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+
+pkgname=nutty
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A network utility for linux. Monitor the devices on your network and check bandwidth and speed details.'
+arch=('i686' 'x86_64')
+url='https://github.com/babluboy/nutty'
+license=('GPL3')
+depends=('gtk3' 'granite' 'sqlite' 'libxml2' 'libnotify' 'libgee' 'net-tools' 'nethogs' 'nmap' 'traceroute' 'vnstat' 'curl' 'wireless_tools' 'iproute2' 'pciutils')
+makedepends=('vala' 'meson')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+install="${pkgname}.install"
+source=("https://github.com/babluboy/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('b6c9ef1966d1c60480943313f20cd66ee1b5d23ac8d6578f457fb99f0898d9ba')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}
+
+
+build() {
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ arch-meson
+ ninja
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ DESTDIR=${pkgdir} ninja install
+}
+