summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarc-Olivier Barre2021-01-20 11:07:44 +0100
committerMarc-Olivier Barre2021-01-20 12:51:15 +0100
commit0894e8bc463c275f1a51f93ae2a6cf494bf7676b (patch)
tree17542cec03bc47a2a006e2fcaa56f10be073fdbc /PKGBUILD
parentba7a3c784c0e35fce491a4f2cc33307be0298b52 (diff)
downloadaur-oacapture-git.tar.gz
Make this into a generic git package
Add missing patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23917bfd1311..2b13bc0f77d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
pkgname=oacapture-git
-pkgver=bb7f8e6
+_gitname=openastro
+pkgver=v1.8.0.1098.adef9b5b
pkgrel=1
pkgdesc="A planetary imaging application using Qt5"
provides=("oacapture")
@@ -9,19 +10,28 @@ license=('GPLv3')
depends=('qt5-base' 'qt5-tools' 'cfitsio' 'autoconf-archive' 'sdl' 'libdc1394')
url="http://www.openastroproject.org/oacapture/"
optdepends=('fxload: support for QHY5 cameras')
+source=("git+https://github.com/openastroproject/openastro.git" "oacapture-slash-lib.diff" "libhidapi-configure-ac.diff")
+sha256sums=("SKIP" "813e80ef718e0e9887c5293ef435b1cff43d03ae8c2bb6a2d53f0bbbf4a284f2" "204c6d6dea820fa9564026df4d0bd15d866bd9904d0afd3e51c3fd7ddf69a844")
+provides=($_gitname=$pkgver)
+conflicts=($_gitname)
+replaces=($_gitname)
-source=("openastro-$pkgver::git+https://github.com/openastroproject/openastro#commit=${pkgver}")
-sha256sums=("SKIP")
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "%s.%s.%s" "$(git describe --tags | cut -d "-" -f1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "openastro-${pkgver}"
+ cd "openastro"
+ patch -Np1 < ${srcdir}/oacapture-slash-lib.diff
+ patch -Np1 < ${srcdir}/libhidapi-configure-ac.diff
./bootstrap
./configure --prefix=/usr
make
}
package() {
- cd "openastro-${pkgver}"
+ cd "openastro"
make DESTDIR="${pkgdir}" install
# remove unwanted files