summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Denizart2023-07-08 22:55:27 +0200
committerHugo Denizart2023-07-08 22:55:27 +0200
commit30d1a6507d32cdc6a01e057de62759cbe603f9f2 (patch)
treea96486298923d34ec93d3d25797729e0654bab73 /PKGBUILD
parentf7707aa74be28ed5007916b830aae8f65bb50fae (diff)
downloadaur-obs-streamfx-git.tar.gz
🐛 Upgrade to Qt 6, remove ffmpeg support patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5aa42d72baf..1e8f9826b933 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hugo Denizart <hugo at denizart dot pro>
pkgname=obs-streamfx-git
-pkgver=0.12.0b191.r10.g5dfb8bca
+pkgver=0.12.0b299.r0.g8b97c2b2
pkgrel=1
pkgdesc="Bring your stream back to life with modern effects!"
arch=("x86_64")
@@ -8,16 +8,14 @@ url="https://github.com/Xaymar/obs-StreamFX"
license=("GPL2")
# same dependencies as OBS Studio + nlohmann-json + ninja makedepends
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
- "qt5-x11extras" "curl" "gtk-update-icon-cache"
+ "qt6-base" "curl" "gtk-update-icon-cache"
"obs-studio>=25" "nlohmann-json")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
"vlc" "swig" "luajit" "python" "ninja")
provides=("obs-streamfx")
conflicts=("obs-streamfx")
-source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#branch=root"
- "00001-fix-build-on-ffmpeg-6.patch")
-md5sums=("SKIP"
- "e532ab3c20aa2b40099706990ec92ba0")
+source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#branch=root")
+md5sums=("SKIP")
pkgver() {
cd "$pkgname"
@@ -27,7 +25,6 @@ pkgver() {
prepare() {
cd $pkgname
git submodule update --init --recursive
- git apply ../00001-fix-build-on-ffmpeg-6.patch
}
build() {