summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2021-07-24 08:43:48 -0300
committerRafael Fontenelle2021-07-24 08:43:48 -0300
commit5d1b6654b4f594fbfb75f236f1900e442e9d797e (patch)
tree6339227ba4f6fcddab5dd0cace2639aeb118494b /PKGBUILD
parent16dc88764234c7abf0087f92abb531270f12f27c (diff)
downloadaur-obs-xdg-portal-git.tar.gz
Fix build
- Replace the deleted obs-studio-wayland in favor of OBS >27 - Fix gs_texture_create_from_dmabuf call adding missing parameter
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b7bfdf2be83..5d72eac92536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
# Contributor: Davide Depau <davide@depau.eu>
pkgname="obs-xdg-portal-git"
-pkgver=0.1.2.r21.g8430c46
+pkgver=0.1.2.r40.gee5241a
pkgrel=1
pkgdesc="OBS Studio plugin using the Desktop portal for Wayland & X11 screencasting"
arch=(x86_64)
url="https://gitlab.gnome.org/feaneron/obs-xdg-portal"
license=('GPL')
-depends=('obs-studio-wayland' 'xdg-desktop-portal')
+depends=('obs-studio>=27' 'xdg-desktop-portal')
makedepends=('meson' 'git')
conflicts=("${pkgname%%-git}")
provides=("${pkgname%%-git}")
-source=("git+$url")
-sha256sums=('SKIP')
+source=("git+$url"
+ "fix-gs_texture_create_from_dmabuf.patch")
+sha256sums=('SKIP'
+ '056fa69ca93b8203a72b7ee5d41ad7fca99fcb1af81a3c61e37b4d699961b18c')
+
+prepare() {
+ cd ${pkgname%%-git}
+ # Add missing parameter to gs_texture_create_from_dmabuf function call
+ # to fix https://gitlab.gnome.org/feaneron/obs-xdg-portal/-/issues/30,
+ # see:
+ # https://gitlab.gnome.org/feaneron/obs-xdg-portal/-/merge_requests/15
+ git apply "$srcdir/fix-gs_texture_create_from_dmabuf.patch"
+}
pkgver() {
cd ${pkgname%%-git}