summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarek Kubica2017-03-06 19:45:30 +0100
committerMarek Kubica2017-03-06 19:58:04 +0100
commitb92e337a3560bdaa7a700a1409a9483a15ed4724 (patch)
tree34a9e581f5e4d8ed7453e274c57f51198d3b72d8 /PKGBUILD
parentbd78af90ceac816250085ab0b8be5919c2f981f6 (diff)
downloadaur-ocaml-oasis.tar.gz
Update to new release, shedding dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5bddaa2148a..5a84a39b1727 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,32 @@
# Contributor: Magnus Therning <magnus@therning.org>
pkgname=ocaml-oasis
-pkgver=0.4.5
+pkgver=0.4.8
pkgrel=1
pkgdesc='Architecture for building OCaml libraries and applications.'
arch=('i686' 'x86_64')
-url=("http://oasis.forge.ocamlcore.org")
+url="http://oasis.forge.ocamlcore.org"
license=('LGPL')
depends=('glibc' 'pcre')
makedepends=('ocaml'
- 'ocaml-batteries'
+ 'ocamlbuild'
'ocaml-fileutils>=0.4.2'
'ocaml-findlib'
- 'ocaml-ocamlgraph'
'ocaml-ocamlify'
- 'ocaml-odn>=0.0.11'
- 'ocaml-ounit'
- 'ocaml-ocamlmod'
- 'ocaml-pcre'
- 'ocaml-expect>=0.0.3')
-source=("http://forge.ocamlcore.org/frs/download.php/1475/oasis-${pkgver}.tar.gz")
-sha512sums=('97d5401762ffda6bf4d7a239d9c77f8647d58da1728925e6de6e8fdfded6f8e7bb69652a838b86ab7203cd68436b06f76921c76840b97db56a94bb87d74450d7')
+ 'ocaml-ocamlmod')
+source=("http://forge.ocamlcore.org/frs/download.php/1669/oasis-${pkgver}.tar.gz")
+sha512sums=('e0baf0f048647c25eac5472db0d2a22d0fcaf85fe61ebd88ec5a101c20d4916ecfa9d10fae069ba4479abb22b90c44f18312b9252727a8c7c7de4aa2d8d72663')
options=(!strip)
build() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
- make CONFIGUREFLAGS="--prefix /usr --destdir $pkgdir --disable-tests" build
+ ocaml setup.ml -configure --prefix "$pkgdir" --exec-prefix "$pkgdir/usr"
+ ocaml setup.ml -build
}
package() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
install -dm755 "$OCAMLFIND_DESTDIR"
- make install
+ ocaml setup.ml -install
}