summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:14:03 +0100
committerDaniel Peukert2024-01-28 00:14:03 +0100
commitd8b5a690dcbfe2f2c9012e142629dd2c821909eb (patch)
tree4100f300410f945593b98f2d211e386e282c51ce /PKGBUILD
parent3b3b723b893e6fff723b072329036ebc05d290f4 (diff)
downloadaur-ocaml-sexplib.tar.gz
Sync pkgbuilds repo with AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cdece6d1fc4..ca8a5900d47e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ epoch='1'
pkgdesc='Library for serializing OCaml values to and from S-expressions'
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
-license=('MIT')
+license=('MIT' 'BSD-3-Clause')
depends=('ocaml>=4.14.0' 'ocaml-num' 'ocaml-parsexp>=0.16.0' 'ocaml-sexplib0>=0.16.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('f924d92ddf11f12be51073a3dfca45486d90b05533f29804518ee86b93386b8ff8d7e692c71d77b11347b78e9f6f6dcf7d79b71540efe54b013fa09b3bab414a')
_sourcedirectory="$_projectname-$pkgver"
@@ -30,7 +30,9 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- for _license in 'COPYRIGHT.txt' 'LICENSE.md' 'LICENSE-Tywith.txt' 'THIRD-PARTY.txt'; do
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE-Tywith.txt" "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
+ for _license in 'COPYRIGHT.txt' 'THIRD-PARTY.txt'; do
ln -sf "/usr/share/doc/$pkgname/$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
done
}