summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-08-10 22:08:38 +0100
committerEmmanuel Gil Peyrot2016-08-10 22:08:38 +0100
commitb65da9a8d22b0f1e9eaef0d92ac25f51ccc8dd79 (patch)
treeefaed5270f80821215b1b84ffd8d2bb8441316fc /PKGBUILD
downloadaur-odhcp6c-git.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2a4369f225d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Lightning <sgsdxzy@gmail.com>
+
+pkgname=odhcp6c-git
+pkgver=v1.1.r54.g7533a62
+pkgrel=1
+pkgdesc='minimal DHCPv6 and RA-client for use in embedded Linux systems'
+arch=('x86_64' 'i686')
+url='https://wiki.openwrt.org/doc/techref/odhcp6c'
+license=('GPL2')
+makedepends=('cmake' 'git')
+provides=('odhcp6c')
+conflicts=('odhcp6c')
+source=('odhcp6c::git+https://github.com/sbyx/odhcp6c')
+md5sums=('SKIP')
+
+pkgver() {
+ cd odhcp6c
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p odhcp6c/build
+}
+
+build() {
+ cd odhcp6c/build
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd odhcp6c/build
+ make DESTDIR="$pkgdir/" install
+ mv "$pkgdir/usr/sbin" "$pkgdir/usr/bin"
+}
+
+# vim: ts=2 sw=2 et: