summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler2020-09-17 11:11:44 -0800
committerTyler2020-09-17 11:17:51 -0800
commitb627aacd73bccae37dfcc7c994d6c3baf0b94f03 (patch)
treedbfd4b4fb85b9c4f3c27332d43bf80d484180173 /PKGBUILD
downloadaur-open-numismat-bin.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fe154b22981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tyler <tyler@cyb3r.space>
+
+pkgname=open-numismat-bin
+pkgver=1.8.7
+pkgrel=1
+pkgdesc='Coin collecting software to organize and manage your own coin catalogue.'
+arch=('any')
+url="http://opennumismat.github.io"
+license=('GPL3')
+groups=('')
+depends=('bash-completion' 'hicolor-icon-theme' 'pyside2' 'python' 'python-dateutil' 'python-jinja' 'python-django' 'python-lxml' 'python-matplotlib' 'python-numpy' 'python-xlrd' 'qt5-base')
+options=('!strip' '!emptydirs')
+install=open-numismat-bin.install
+source=("https://github.com/OpenNumismat/open-numismat/releases/download/${pkgver}/open-numismat_${pkgver}_all.deb")
+sha512sums=('d0d8bc0120b00418adbd6737c31ef59e02435b9430d8ca3b805caf19c73c6628be7d1a326b0a80f2a55795a9f2587c1eebce63c69c5c25636a1f0e5541b167a4')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+ # python3 directory needs to point to correct python-current version, wierd debian python packaging formats
+ LATEST_PYTHON=$(ls -l /usr/bin/python3 | cut -d ">" -f 2 | tr -d '[:space:]')
+ mv "${pkgdir}/usr/lib/python3/" "${pkgdir}/usr/lib/$LATEST_PYTHON/"
+ mv "${pkgdir}/usr/lib/$LATEST_PYTHON/dist-packages" "${pkgdir}/usr/lib/$LATEST_PYTHON/site-packages"
+}