summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Vybíhal2022-11-21 12:53:14 +0100
committerJosef Vybíhal2022-11-21 12:53:14 +0100
commit4611da3822d7a24e343c78c253d02907ba2130b3 (patch)
tree6b0c8a4659f696c1daf3f43dee8b84102ce5a034 /PKGBUILD
parente0d3f9c2548f894424f802eb04311738b13d80c1 (diff)
downloadaur-openfortigui-git.tar.gz
Forked openfortigui into openfortigui-git
pkg opnfortigui seems to be little neglected by maintainer so I deciced to track master upstream branch with this package. Tested building with openssl 3, and is fine. Removed sudoers patch for now. might bring it back later, or not.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5faf16fbb41d..4cc7da8f5167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
-# Maintainer: Charles Delfly <charles@delfly.fr>
-pkgname=openfortigui
-pkgver=0.9.6
+# Maintainer: Josef Vybíhal <josef.vybihal@gmail.com>
+# Contributor: Charles Delfly <charles@delfly.fr>
+
+pkgname=openfortigui-git
+_pkgname="${pkgname%-git}"
+pkgver=0.9.8.1.r0.g31eff99
pkgrel=1
pkgdesc="OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5."
arch=('i686' 'x86_64')
@@ -9,40 +12,47 @@ license=('GPL3')
groups=()
depends=('qt5-base' 'qtkeychain' 'qt5-translations' 'openssl' 'ppp' 'sudo')
makedepends=('git')
-provides=()
-conflicts=()
+provides=(openfortigui)
+conflicts=(openfortigui)
replaces=()
options=()
install=
-source=("git+https://github.com/theinvisible/$pkgname.git#tag=v$pkgver" "user-env.patch")
+source=("git+https://github.com/theinvisible/$_pkgname.git")
noextract=()
-md5sums=('SKIP' '7f1e96dea4ce324b59b8190640f22c43')
+b2sums=('SKIP')
+#options=(debug !strip)
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
cd openfortigui
git submodule init
git submodule update
cd ..
- patch -p1 < ../user-env.patch
+ #patch -p1 < ../user-env.patch
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
+ #qmake openfortigui-project.pro -spec linux-g++ CONFIG+=debug CONFIG+=qml_debug
qmake
make
}
check() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
make -k check
}
package() {
- cd "$srcdir/$pkgname/openfortigui"
+ cd "$srcdir/${_pkgname}/${_pkgname}"
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/pixmaps $pkgdir/usr/share/applications $pkgdir/etc/sudoers.d $pkgdir/etc/openfortigui/vpnprofiles
install -m 755 openfortigui $pkgdir/usr/bin/
- chmod 640 $pkgdir/etc/sudoers.d
+ #chmod 640 $pkgdir/etc/sudoers.d
install -m 440 sudo/openfortigui $pkgdir/etc/sudoers.d
install -m 644 app-entry/openfortigui.png $pkgdir/usr/share/pixmaps/
install -m 644 app-entry/openfortigui.desktop $pkgdir/usr/share/applications/