summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2023-01-21 13:49:18 -0300
committerDaniel Bermond2023-01-21 13:49:18 -0300
commit655ea80a7b97071a02612968cd0d3e9d9ce5853f (patch)
tree1f7b307c5a4027abc43e6aaa4eb46bf5e3b75209 /PKGBUILD
parent97b3a44d4618918906f65a4c79cb3469aa5bc244 (diff)
downloadaur-openshot-git.tar.gz
Update dependencies and build commands
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae6fbcd4cccc..63222b0516ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
pkgname=openshot-git
-pkgver=2.4.4.r601.g1a7ebc1f
+pkgver=3.0.0.r25.g369b68de
pkgrel=1
pkgdesc='An open-source, non-linear video editor for Linux based on MLT framework (git version)'
arch=('any')
url='https://www.openshot.org/'
license=('GPL3')
-depends=('ffmpeg' 'python-mlt' 'python-pyqt5' 'python-requests' 'libopenshot-git'
- 'libopenshot-audio-git' 'python-pyzmq' 'qt5-base' 'qt5-svg' 'qt5-webkit')
-makedepends=('git' 'python-setuptools')
+depends=('ffmpeg' 'python-pyqt5' 'python-pyzmq' 'python-requests' 'qt5-base' 'qt5-svg'
+ 'python-pyqt5-webengine' 'libopenshot-git' 'libopenshot-audio-git')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=('faac: for exporting audio using AAC')
provides=('openshot')
conflicts=('openshot')
@@ -17,16 +17,19 @@ source=('git+https://github.com/OpenShot/openshot-qt.git')
sha256sums=('SKIP')
pkgver() {
- cd openshot-qt
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C openshot-qt describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
cd openshot-qt
- python setup.py build
+ python -m build --wheel --no-isolation
}
-package() {
+check() {
cd openshot-qt
- python setup.py install --root="$pkgdir" --skip-build --optimize='1'
+ python -m unittest discover -vs src/tests
+}
+
+package() {
+ python -m installer --destdir="$pkgdir" openshot-qt/dist/*.whl
}