summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohan Förberg2017-04-01 18:17:41 +0200
committerJohan Förberg2017-04-01 18:17:41 +0200
commit39caee2590628b60fba6a0c8d2321628a5bd8ecf (patch)
tree7b1fab8fbc1077f38978fbf8f31191c2ed351dd3 /PKGBUILD
downloadaur-openxcom-music-sycraft.tar.gz
Init.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75ddd3c405d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johan Förberg <johan@forberg.se>
+pkgname=openxcom-music-sycraft
+pkgver=6.0
+pkgrel=1
+pkgdesc='Remixed soundtrack by Sycraft for use with OpenXcom'
+arch=(any)
+url=http://sycraft.org/content/audio/xcom.shtml
+depends=(openxcom)
+install=openxcom-music-sycraft.install
+license=(custom)
+
+source=(http://sycraft.org/content/audio/xcom/sycraft-xcom-ogg.zip)
+sha1sums=('ce71c24495c808a74ee33e00e9b80bfe496c1a97')
+
+prepare() {
+ cd "$srcdir"
+
+ # Extract 'license' part of readme per Arch packaging standards.
+ sed -n '1,2p; 20,23p' Sycraft_music_readme.txt > LICENSE
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 *.ogg Sycraft_music_readme.txt -t "$pkgdir/usr/share/openxcom/UFO/SOUND"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}