summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2021-09-11 08:12:49 +0900
committerQue Quotion2021-09-11 08:12:49 +0900
commit10613c4621ae73f7b06d1fcdd61f8728bfa88754 (patch)
tree3591cbb47c760a961cd9eeda960a08f419316025 /PKGBUILD
parent805e5b8a6f9e6909062a8aa89430b8f3d1431d47 (diff)
downloadaur-pantheon-qq-common.tar.gz
rely on pantheon-session; reduce optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 5 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36564ead4cca..6a2c51d70eed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,19 @@
# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
pkgname=pantheon-qq-common
-pkgver=1
-pkgrel=2
+pkgver=2
+pkgrel=1
pkgdesc='Common dependencies of Pantheon 3D and Pantheon Lite'
arch=('any')
url='https://github.com/quequotion/pantheon-qq'
license=('GPL3')
groups=('pantheon-qq')
-depends=({cinnamon,pantheon}-settings-daemon gnome-{keyring,session} 'xdg-user-dirs-gtk'
- wingpanel pantheon-{dock,applications-menu})
-optdepends=("contractor: A desktop-wide extension service"
- "dconf-editor: GUI gsettings editor"
- "elementary-blue-icon-theme-git: Restore blue folder icons to elementary theme"
+depends=(pantheon-session)
+optdepends=("elementary-blue-icon-theme-git: Restore blue folder icons to elementary theme"
"file-roller-pantheon: Archive manipulator for GNOME (with elementary OS patches)"
"lightdm-gtk-greeter: GTK+ Greeter for LightDM"
"numlockx: Turn on the numlock key in X11"
- "pantheon-calculator: The Pantheon Calculator"
- "pantheon-calendar: The Pantheon Calendar"
- "pantheon-code: The Pantheon Code Editor"
- "pantheon-default-settings: Default settings for Pantheon"
- "pantheon-dock-instctl-git: Dock for Pantheon with instance controls"
- "pantheon-dpms-helper: DPMS helper for Pantheon"
- "pantheon-files: The Pantheon File Browser"
- "pantheon-geoclue2-agent: Pantheon Geoclue2 Agent"
- "pantheon-music: The Pantheon Music Player"
- "pantheon-notifications: A Gtk notification server for Pantheon"
- "pantheon-photos: The Pantheon Photos Manager"
- "pantheon-polkit-agent: Pantheon Polkit Agent"
- "pantheon-print: Simple shim for printing support via Contractor"
- "pantheon-screenshot: The Pantheon Screenshot Tool"
- "pantheon-terminal: The Pantheon Terminal Emulator"
+ "pantheon-dock-instctl-git: Dock for Pantheon (with instance controls)"
"xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops"
"wingpanel-standalone-git: Stylish top panel (with autohide and without Gala dependencies)")
conflicts=('pantheon-workarounds')
@@ -48,14 +31,5 @@ package() {
#Script to initiate Pantheon derivative gnome-sessions
install -Dm755 {"${srcdir}","${pkgdir}"/usr/bin}/pantheon-session-qq
- #Use cinnamon-settings-daemon (gnome-settings-daemon has deprecated modularity and xorg)
- #Skip "Screensaver" plugin in Pantheon: session-indicator needs org.gnome.ScreenSaver.Lock
- #Skip "Xrandr" plugin in Pantheon: monitors.xml configuration doesn't seem to work, is undocumented, etc.
- for i in /etc/xdg/autostart/cinnamon-settings-daemon-*.desktop; do
- if [[ ${i} != *screensaver* ]] && [[ ${i} != *xrandr* ]] && [[ ${i} != *pantheon* ]]; then
- sed s/X-Cinnamon/Pantheon/ "${i}" > "${pkgdir}${i/.desktop/-pantheon.desktop}"
- fi
- done
-
echo "Get the latest dotfiles: https://gist.github.com/quequotion/a7c2e82451a87a05dbca50e5e8176615"
}