summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWillem Mulder2023-02-04 11:34:22 +0100
committerWillem Mulder2023-02-04 11:34:22 +0100
commitf695acadab83e76edd6131c147d595574bb80736 (patch)
tree78fd309e9e6846301cf0a286e58e211dca70726f /PKGBUILD
parent5339ccbe292ab79100b29eb3935fe4695a2fb864 (diff)
downloadaur-passff-host-git.tar.gz
Fix passff version string, pre-compile python code
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d89131aa057e..2bf7bdf1b1f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Willem Mulder <14mRh4X0r@gmail.com>
_pkgname=passff-host
pkgname=$_pkgname-git
-pkgver=1.0.1.r7.1feab77
+pkgver=1.2.3.r6.8fcae33
pkgrel=1
pkgdesc="Host app for the WebExtension PassFF"
arch=(any)
@@ -22,10 +22,14 @@ pkgver() {
package() {
cd "$_pkgname"
- sed -i -e '1c#!/usr/bin/python3' -e s/_VERSIONHOLDER_/${pkgver}/g src/passff.py
+ semver="$(git describe --tags --long | sed 's/-.*g/+g/')"
+ sed -i -e '1c#!/usr/bin/python3' -e s/_VERSIONHOLDER_/${semver}/g \
+ src/passff.py
install -Dm755 src/passff.py \
"${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.py"
+ python -O -m compileall "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.py"
+
jq '.path = "/usr/lib/mozilla/native-messaging-hosts/passff.py"' src/passff.json \
> "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.json"
}