summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Guillaumin2018-05-19 18:30:57 -0700
committerNicolas Guillaumin2018-05-19 18:30:57 -0700
commit8f66b291ad8baa407b25626e4cea3bf063f26071 (patch)
treec3ca0904c5c896a5104086be1c5eb383a8b1f74f /PKGBUILD
downloadaur-perl-uri-redis.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ae9f9cf3f98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Nicolas Guillaumin <nicolas plus archlinux at guillaumin dot me>
+pkgname=perl-uri-redis
+pkgver=0.02
+pkgrel=1
+pkgdesc='URI for Redis connection info'
+_dist=URI-redis
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl perl-uri)
+makedepends=(perl-test-most perl-module-install)
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/M/ME/MENDEL/$_dist-$pkgver.tar.gz")
+md5sums=(ed86ee5019e5e038ee9d8f727a0972e9)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}