summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnna Ivanova2017-04-15 21:51:48 +0500
committerAnna Ivanova2017-04-15 22:50:01 +0500
commitb7aac5df291d748a8c99c798957d8140c48bc06a (patch)
tree744d6118f2a0539db2f023f8e049f44587e256cd /PKGBUILD
downloadaur-playmusicdecrypter-git.tar.gz
Initial commit with the first variant of the PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93fe6b1994a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Anna Ivanova <kalterfx@gmail.com>
+
+pkgname='playmusicdecrypter-git'
+
+pkgver='v1.0.r8.g5a2318a'
+function pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/-/.r/;s/-/./'
+}
+
+pkgrel='1'
+pkgdesc='Decrypt MP3 files from Google Play Music offline storage (All Access)'
+url='https://github.com/playmusicdecrypter'
+license=( 'GPL3' )
+
+source=( "$pkgname::git+https://github.com/playmusicdecrypter/playmusicdecrypter" )
+md5sums=( 'SKIP' )
+
+arch=( 'any' )
+depends=( 'python2' 'python2-crypto' 'mutagen' )
+optdepends=( 'android-tools' )
+
+function package() {
+ cd "$pkgname"
+ ./setup.py install --root "$pkgdir"
+ install -Dv -T -- {.,"$pkgdir/usr/share/licenses/$pkgname"}/LICENSE
+}
+