summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2017-07-03 16:48:27 -0600
committerBrian Bidulock2017-07-03 16:48:27 -0600
commita45c4a0594a73dd955f08b41cd9de58ac3bad018 (patch)
tree4e76db02ba2c986066f209e38b8120d26c478285 /PKGBUILD
parentf7273a29a2abd7cefedb99341a97c98dc4738a42 (diff)
downloadaur-pnmixer.tar.gz
version 0.7.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5b59410bd9d..d8a3e4f18e6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=pnmixer
-pkgver=0.7
+pkgver=0.7.2
pkgrel=1
pkgdesc="GTK volume mixer applet that runs in the system tray."
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/nicklan/pnmixer"
-makedepends=('intltool')
+makedepends=('intltool' 'cmake')
depends=('gtk2' 'alsa-lib' 'libnotify')
-source=("https://github.com/nicklan/pnmixer/releases/download/v0.7/pnmixer-${pkgver}.tar.gz")
-md5sums=('4ddfab98ad915075aecced01e0890c65')
+source=("https://github.com/nicklan/pnmixer/releases/download/v${pkgver}/pnmixer-v${pkgver}.tar.gz")
+md5sums=('e9f17f56c50de39393030a96e343427b')
build() {
- cd $pkgname-$pkgver
- ./autogen.sh --without-gtk3 --prefix=/usr
- make V=0
+ cd $pkgname-v$pkgver
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DWITH_GTK3=OFF
+ make
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname-v$pkgver
make DESTDIR="$pkgdir" install
}