summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-07-26 18:17:17 +0000
committerBioArchLinuxBot2023-07-26 18:17:17 +0000
commitedb242e5e7e47ecd804d107f5e72c46b26062ee9 (patch)
treeaac62e3d5716080814ef729cab239eebef1c8db7 /PKGBUILD
parentd8e07a29daedb5094c4ca399a1d375f51b8f58f6 (diff)
downloadaur-preseq.tar.gz
[lilac] updated to 3.2.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7be48e98a730..fca3c1190e61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,27 @@
pkgname=preseq
pkgver=3.2.0
-pkgrel=1
+pkgrel=3
pkgdesc="A tool for predicting and estimating the complexity of a genomic sequencing library, equivalent to predicting and estimating the number of redundant reads from a given sequencing depth."
arch=('x86_64')
url="http://smithlabresearch.org/software/preseq/"
depends=('gsl' 'htslib')
makedepends=('make')
license=('GPL3')
-source=("https://github.com/smithlabcode/preseq/releases/download/v${pkgver}/preseq-${pkgver}.tar.gz")
-md5sums=('293486920e3f6fcdab2418b8413f9cbd')
+source=("https://github.com/smithlabcode/preseq/releases/download/v${pkgver}/preseq-${pkgver}.tar.gz"
+ "$pkgname-3.2.0.patch")
+md5sums=('293486920e3f6fcdab2418b8413f9cbd'
+ '56a5e2d72618d28f45ac001857fe4a7c')
prepare() {
cd "${pkgname}-${pkgver}"
- ./configure --prefix="${pkgdir}/usr" --enable-hts
+ cd src/smithlab_cpp
+ patch -p1 < $srcdir/$pkgname-3.2.0.patch
}
build() {
cd "${pkgname}-${pkgver}"
+ ./configure --prefix="${pkgdir}/usr" --enable-hts
make all
}