summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher2024-03-10 21:51:34 -0400
committerChristopher2024-03-10 21:51:34 -0400
commit1f50886dfd04667e1d691cf435f98accc6d8f253 (patch)
tree7a2cb6dc0e6703c595e56e8bb39a5152b474281b /PKGBUILD
downloadaur-proid-git.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c005feea262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christopher <archlinux-maintainer@christopherz.com>
+
+pkgname="proid-git"
+pkgver=r11.480742a
+pkgrel=1
+pkgdesc="A tool to hide and show windows in X"
+arch=("any")
+url="https://gitlab.com/rehposuite/proid"
+license=("GPL")
+depends=("xdotool")
+makedepends=("stack")
+provides=("proid")
+source=("git+${url}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "proid"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd "proid"
+
+ stack setup
+ stack build
+}
+
+package() {
+ cd "proid"
+
+ find ./ -path '*/dist/*' -type f -name proid -perm /u+x \
+ -execdir install -Dm755 -t "$pkgdir/usr/bin/" {} \;
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}