summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Conrad2015-10-30 00:12:55 +0100
committerStephan Conrad2015-10-30 00:12:55 +0100
commit5e4acac5a2dcd7affd58fb1a402d41aa1804eb13 (patch)
tree47224f3696ef46b23b67d6d80e1af21ddc5331e3 /PKGBUILD
downloadaur-pypam2-bzr.tar.gz
added pypam2-bzr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90d0a290d686
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=pypam2-bzr
+pkgver=17
+pkgrel=1
+arch=('any')
+license=('GPL')
+makedepends=('bzr')
+depends=('pam' 'python2')
+url="https://launchpad.net/ubuntu/quantal/+source/python-pam"
+pkgdesc="A Python interface to the PAM library (configured to build for python2)"
+conflicts=('pypam2')
+provides=('pypam2')
+
+_urel="quantal"
+_bzrtrunk="http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/${_urel}/python-pam/${_urel}"
+_bzrmod=python-pam
+
+build()
+{
+ cd "${srcdir}"
+ if [[ -d "$_bzrmod" ]]; then
+ cd "$_bzrmod" && bzr --no-plugins pull "$_bzrtrunk" -r "$pkgver"
+ msg "The local files are updated."
+ else
+ bzr --no-plugins branch "$_bzrtrunk" "$_bzrmod" -q -r "$pkgver"
+ cd python-pam
+ fi
+ python2 setup.py build
+}
+
+package()
+{
+ cd "${srcdir}/python-pam"
+ python2 setup.py install --root="${pkgdir}"
+}