summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Kudelin2022-09-13 22:01:28 +0300
committerAnton Kudelin2022-09-13 22:01:28 +0300
commitb7fe6cd267be4f5444783f9b2fbb6fc8184e4a7f (patch)
treeefb8c90cfa1a2ebb97ac696ed5a765f40a761c7b /PKGBUILD
parentc59f2c68f0e567536d1dd4fe520c4b5542726369 (diff)
downloadaur-python-dateutils.tar.gz
upddeps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32f9cbe1b684..649a2a18a037 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,23 @@
_pkgname=dateutils
pkgname=python-$_pkgname
pkgver=0.6.12
-pkgrel=1
-pkgdesc="Utilities for working with datetime objects."
+pkgrel=2
+pkgdesc="Utilities for working with datetime objects"
arch=('any')
-url="https://github.com/plytophogy/python-dateutils"
+url="https://github.com/jmcantrell/python-dateutils"
license=('ISC')
-depends=('python-dateutil' 'python-argparse' 'python-pytz')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('03dd90bcb21541bd4eb4b013637e4f1b5f944881c46cc6e4b67a6059e370e3f1')
+depends=('python-dateutil' 'python-pytz')
+makedepends=('python-setuptools')
+source=($pkgname-$pkgver.tar.gz::"$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('a7633f065542c5550e719622ac72f6f2d67e9b0a6af0d4b0cc13e0b9eab006aa')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" -O1 --skip-build
install -Dm755 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}