summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 21:08:47 -0700
committerGI_Jack2023-05-13 21:08:47 -0700
commit584f5d8c92b97051418d97fc861d2fe8e449df2e (patch)
tree828c7dcf7bf39a77d9c3e0d17325de4c60d99bce /PKGBUILD
parentd996d73c8cf9a1a1efecdef772b00e26c53af102 (diff)
downloadaur-python-delete-tweets.tar.gz
updated to modern packaging guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b493ef7854e..e8a87dbc8394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
pkgname=python-delete-tweets
_pkgname=delete-tweets
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="a simple script that helps you delete tweets (or just replies or retweets) from your timeline"
url="https://github.com/koenrh/delete-tweets"
arch=('any')
license=('custom:isc')
depends=('python' 'python-twitter3' 'python-dateutil')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://github.com/koenrh/delete-tweets/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('cf19eae62899ce4573136d5c59a26e4b600bdf03129766b826255f5b1ec2e382')
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}