summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán2024-05-01 16:32:17 -0500
committerCarlos Aznarán2024-05-01 16:32:17 -0500
commit407119c1e27ed4fd5e3c038169182ea0e0bf262f (patch)
tree6739230de506d24c41250d307ee5ce52965ffa35 /PKGBUILD
parentff50e56bd8fa3e9550054b787cf15fc593ee3864 (diff)
downloadaur-python-devito.tar.gz
Bump version to 4.8.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62987fc53d0a..cc3ab9706d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=devito
pkgname=python-${_base}
-pkgver=4.8.5
+pkgver=4.8.6
pkgrel=1
pkgdesc="Finite Difference DSL for symbolic computation"
arch=(any)
url="https://github.com/${_base}codes/${_base}"
license=(MIT)
-depends=(python-cached-property python-psutil python-py-cpuinfo
- python-codepy python-multidict python-anytree python-sympy)
-makedepends=(python-build python-installer python-setuptools python-wheel openmp)
-# checkdepends=(python-pytest python-scipy python-matplotlib python-nbval python-cloudpickle)
+depends=(python-sympy python-cached-property python-psutil python-py-cpuinfo
+ python-codepy python-multidict python-anytree python-cloudpickle python-click)
+makedepends=(python-build python-installer python-setuptools python-wheel openmp git)
+# checkdepends=(python-pytest python-scipy python-nbval python-matplotlib)
optdepends=('python-mpi4py: for parallel support'
- 'python-ipyparallel: for parallel support') # python-click
+ 'python-ipyparallel: for parallel support')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('adc2fd7b6f3aa577b3287132e37f64e9997e2694fc62bf48d8f968ee1b46746cdcd75470e20ae9cc02ec235f12815a0fd1cde80c4ea22160e23529e5c018359a')
+sha512sums=('7c59990352742d35d32dd65aa45e953940382fb1c78577840d9d4841739326f958af3192229a29808bcdf6435e15ea4b383bd9975a3857a6acd17c982b2dc15f')
build() {
cd ${_base}-${pkgver}
@@ -26,8 +26,7 @@ build() {
# python -m venv --system-site-packages test-env
# test-env/bin/python -m installer dist/*.whl
# DEVITO_ARCH=gcc DEVITO_MPI=1 OMP_NUM_THREADS=1 \
-# test-env/bin/python -m pytest tests/test_mpi.py \
-# -k 'not partitioning and not partitioning_fewer_dims and not partitioning_fewer_dims_timefunc and not neighborhood_horizontal_2d and not neighborhood_diagonal_2d and not ctypes_neighborhood and not custom_topology and not halo_exchange_bilateral and not halo_exchange_bilateral_asymmetric[paddings0] and not halo_exchange_bilateral_asymmetric[paddings1]'
+# test-env/bin/python -m pytest tests/test_mpi.py
# }
package() {