summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Owens2020-04-29 18:48:42 -0500
committerNathan Owens2020-04-29 18:48:58 -0500
commit8637431c0df0ad49b744c62404e3270cc20a8ee0 (patch)
tree317e1a46322285950ccdab3f544a122aba38c3c6 /PKGBUILD
parenta74f5711d0d5f05dc19bacd61d73b9b98859308a (diff)
downloadaur-python-dnsimple.tar.gz
Update to 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 170b4deae8e2..c8e2aadacde1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: itsme <mymail@ishere.ru>
-
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
pkgname=python-dnsimple
pkgdesc="Python client for DNSimple domain registration and DNS hosting"
-pkgver=0.3.6
+pkgver=1.2.0
pkgrel=1
arch=('any')
url="https://github.com/onlyhavecans/dnsimple-python"
license=('MIT')
-makedepends=('python-pip')
+makedepends=('python-pip' 'git')
depends=('python' 'python-requests')
-source=("https://github.com/onlyhavecans/dnsimple-python/archive/$pkgver.tar.gz")
-md5sums=('2102b56025a75bb7c6dbdfc4d66b59fa')
-sha256sums=('4a8fd76b83fadc282b8fd087af7c4f1f14657f880d71d5f06fe569cbbb0b3b11')
-
+source=("git+https://github.com/onlyhavecans/dnsimple-python#tag=${pkgver}")
+sha256sums=('SKIP')
package() {
- cd $srcdir/dnsimple-python-$pkgver
+ cd $srcdir/dnsimple-python
python setup.py install --root="$pkgdir/" --optimize=1
}