summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Laß2023-07-30 14:31:59 +0200
committerMichael Laß2023-07-30 14:32:29 +0200
commit11b1a461e154498dd1c1d9a62ecb8d99eef50449 (patch)
tree9140c7b179c39aec8d93af75b351a84190e029f7 /PKGBUILD
parenta961172cd7b65df493d307b743b9ce76d5f8fc94 (diff)
downloadaur-python-dotmap.tar.gz
Adopt PEP 517, fix build warnings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84991333ff80..95614c3ebfed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,31 @@
pkgname=python-dotmap
_name=dotmap
pkgver=1.3.30
-pkgrel=1
+pkgrel=2
pkgdesc="Ordered, dynamically-expandable dot-access dictionary"
arch=('any')
url="https://github.com/drgrib/dotmap"
license=('MIT')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('5821a7933f075fb47563417c0e92e0b7c031158b4c9a6a7e56163479b658b368')
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ fix-setup.cfg.patch)
+sha256sums=('5821a7933f075fb47563417c0e92e0b7c031158b4c9a6a7e56163479b658b368'
+ 'b2f1d6972fbd169684f36c4958f7167c81a85d4aab126c11d1fcad1bfbc121ee')
+
+prepare() {
+ cd "$_name-$pkgver"
+ patch -p1 < "$srcdir"/fix-setup.cfg.patch
+}
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}