summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCyrilWaechter2024-01-01 11:04:16 +0100
committerCyrilWaechter2024-01-01 11:04:16 +0100
commite2d051d67fe070f676a57a415d4102c612a1a07d (patch)
tree1adf1bb3254d6db3842078d4a493348ea046261d /PKGBUILD
downloadaur-python-fcl.tar.gz
Update to 0.7.0.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06b7758bcd84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Cyril <cyrwae[at]hotmail[dot]com>
+pkgname=python-fcl
+pkgver=0.7.0.5
+pkgrel=1
+pkgdesc="Python bindings for the Flexible Collision Library"
+arch=('x86_64')
+url="https://github.com/BerkeleyAutomation/python-fcl"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(python-build python-installer python-wheel)
+optdepends=()
+provides=('python-fcl')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+_py=cp311
+source_x86_64=(https://files.pythonhosted.org/packages/$_py/${pkgname::1}/$pkgname/${pkgname//-/_}-$pkgver-$_py-${_py}-manylinux_2_17_x86_64.manylinux2014_x86_64.whl)
+noextract=()
+md5sums_x86_64=('f4286584d79f65d65a5319c49d43effb')
+
+package() {
+ python -m installer --destdir="$pkgdir" *.whl
+}