summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Hirzel2024-04-19 16:35:55 -0400
committerAlex Hirzel2024-04-19 16:35:55 -0400
commit0f20e96a26b71880b6c729bd6cb55dbaa82addb3 (patch)
treea14fceba0370c180be5f804331334da91cd9f559 /PKGBUILD
parent7112b0383e254a01966de01bc16fd763a03f1854 (diff)
downloadaur-python-jsonargparse.tar.gz
update to version 4.28.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ed39a3b172d..83f6c1188ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python-jsonargparse
_name=${pkgname#python-}
-pkgver=4.27.7
+pkgver=4.28.0
pkgrel=1
pkgdesc='Parsing library for CLI options, configs, and environment variables'
arch=('any')
@@ -24,11 +24,15 @@ depends=(
'python-responses'
'python-ruyaml'
)
+optdepends=(
+ 'python-omegaconf'
+ 'python-jsonnet'
+)
checkdepends=(
'python-coverage'
)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('480fa4b2f4c75f267cbaa13fbf4dc86553f27252041d1d9066f2d0e25bf6389b')
+sha256sums=('ac835a290ef18cc2a5309e6bfa8ada9c5d63f46ff18701583fc8f3e95314679c')
build() {
cd "${srcdir}/${_name}-${pkgver}"