summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-05-29 15:20:00 -0700
committerxiota2023-05-29 15:20:00 -0700
commit88cdc3cb918bfd2abfe3c7044fb6e98ede72b699 (patch)
tree1e921f35a5c7033d89829e5a3c73b9a936aad205 /PKGBUILD
parentb5f64c917c5a4d6de00b6ada18c3323f426f6ecf (diff)
downloadaur-python-omr.tar.gz
update depends, build, package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 17 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 671bd6371e2f..dde96bbfb868 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
+# Maintainer:
# Contributor: Sebastian Lau <lauseb644@gmail.com>
pkgname='python-omr'
_module='omr'
pkgdesc="Extract answer choices from scanned jpg bubble forms"
pkgver='0.0.73'
-pkgrel=2
-_url='http://github.com/GregoryCMiller/omr'
+pkgrel=3
+# http://github.com/GregoryCMiller/omr
url='https://pypi.org/project/omr'
arch=('any')
-license=('Custom')
+license=('unknown')
+
depends=(
+ 'python-numpy'
+ 'python-openpyxl'
+ 'python-pillow'
'python-setuptools'
+ 'python-yaml'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
)
-makedepends=()
+
source=(
"https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
)
@@ -27,24 +38,10 @@ prepare() {
build() {
cd "$srcdir/$_module-$pkgver"
- python setup.py build
+ python -m build --no-isolation --wheel
}
package() {
- depends+=(
- 'python-atomicwrites'
- 'python-importlib-metadata'
- 'python-opencv'
- 'python-openpyxl'
- 'python-pillow'
- 'python-py'
- 'python-pyparsing'
- 'python-pytest'
- 'python-six'
- 'python-wcwidth'
- 'python-yaml'
- )
-
cd "$srcdir/$_module-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}