summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2024-05-07 23:51:34 -0400
committerTed Alff2024-05-07 23:51:34 -0400
commitd793218570ee3e5da2da0c88643ec44abd682bf5 (patch)
tree664eece96da6687e5119a0301798f864174ecfc6 /PKGBUILD
parent24382c402b152eee28d621fa4508c673afc7ec95 (diff)
downloadaur-python-polib.tar.gz
Don't call setup.py directly.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cc46eadc67e..cfd9a15c0194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@ pkgbase=python-polib
pkgname=('python-polib')
_pkgname=polib
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A library to manipulate gettext files'
url='https://pypi.python.org/pypi/polib'
arch=('any')
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("${pkgbase}-${pkgver}.tar.gz::https://pypi.io/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('f3ef94aefed6e183e342a8a269ae1fc4742ba193186ad76f175938621dbfc26b')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}