summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-21 20:13:06 +0700
committerAchmad Fathoni2022-03-21 20:13:06 +0700
commit52cf3e90f6893a21e0f9535b8f0c4446dc0f8370 (patch)
tree6c8a57db4f7e68cf812fcc5336597d5a4b8100f1 /PKGBUILD
downloadaur-python-pyally.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68cda4d50b92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-pyally
+_pkgname=${pkgname:7}
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Ally Invest API Wrapper"
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('MIT')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-pandas python-pytz python-requests python-requests-oauthlib)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('d5dba065ddbf18261b83e29e5fffff731d9b03a4278eb9a9333a17f2d1772d4d')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}