summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2023-12-16 00:57:35 +0800
committertaotieren2023-12-16 00:57:35 +0800
commit480edea47c07ea1fc18817a13d9e10921b1a0553 (patch)
treed7260004ef7b720ac6021603a9e15ba79c64c746 /PKGBUILD
parent2a5fde7003cd90ead7455611d81c26fede924ac5 (diff)
downloadaur-python-pydevicetree.tar.gz
[lilac] updated to 0.0.13-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd44f35be2c9..37fe6fc3694e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=python-pydevicetree
-pkgver=0.0.12
+_name=${pkgname#python-}
+pkgver=0.0.13
pkgrel=1
epoch=
pkgdesc="This is a Python 3 library for parsing, querying, and modifying Devicetree Source v1 files as described in the Devicetree Specification v0.2."
@@ -10,7 +11,10 @@ url="https://github.com/sifive/pydevicetree"
license=('Apache')
groups=()
depends=('python')
-makedepends=("python-setuptools")
+makedepends=(python-build
+ python-installer
+ python-wheel
+ python-setuptools)
checkdepends=()
optdepends=()
provides=()
@@ -20,17 +24,17 @@ backup=()
options=('!strip')
install=
changelog=
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+source=("${_name}-${pkgver}.zip::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
noextract=()
-sha256sums=('910ff471da29151ba77ad0866b78affaa3570e273cab9c134d8571672d7975f2')
+sha256sums=('5700c05df89bad8fd729c11aa6f764a3323bcb3796f13b32481ae34445cfc1b7')
#validpgpkeys=()
build() {
- cd "${srcdir}/${pkgname#python-}-${pkgver}"
- python setup.py build
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${pkgname#python-}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}