summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-21 14:54:49 -0500
committerCarlos Aznarán Laos2023-05-21 14:54:49 -0500
commitb943a1cf7d1d88d9ef7fce7b3dee496da59de3da (patch)
tree749f4607eed95a89b45e5ba6f85641c6d9c15873 /PKGBUILD
parent6c33a03c7066f240929c660e36588bb37f293b0f (diff)
downloadaur-python-pydna.tar.gz
Bump version to 5.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 30 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0bc85735886c..e63633b32129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,40 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Clint Valentine <valentine.clint@gmail.com>
-
-pkgname=python-pydna
-pkgver=4.0.7
-pkgrel=2
-pkgdesc='Data structures for double-stranded DNA & simulation of homologous recombination'
-arch=('any')
-url='https://github.com/bjornfjohansson/pydna'
-license=('BSD')
-depends=(
- 'python-appdirs'
- 'python-biopython'
- 'python-networkx'
- 'python-prettytable'
- 'python-pyparsing'
- 'python-requests')
-optdepends=(
- 'python-matplotlib: gel simulation'
- 'python-mpldatacursor: gel simulation'
- 'python-numpy: gel simulation'
- 'python-pint: gel simulation'
- 'python-scipy: gel simulation')
-makedepends=(
- 'git'
- 'python-build'
- 'python-installer'
- 'python-wheel'
- 'python-sphinx'
- 'python-setuptools'
- 'python-setuptools-scm'
- 'python-pytest-runner')
-checkdepends=('python-requests-mock' 'ipython' 'python-codon-adaptation-index')
-changelog=CHANGELOG.md
-source=("$pkgname::git+$url#tag=$pkgver")
-sha256sums=('SKIP')
+_base=pydna
+pkgname=python-${_base}
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="Representing double stranded DNA and functions for simulating cloning and homologous recombination between DNA molecules"
+arch=(any)
+url="https://github.com/bjornfjohansson/${_base}"
+license=('custom:BSD-3-clause')
+depends=(python-appdirs python-biopython python-networkx python-prettytable python-pyperclip python-pyfiglet)
+makedepends=(python-build python-installer python-poetry-dynamic-versioning python-wheel git)
+checkdepends=(python-pytest python-requests-mock ipython) # python-cai2
+optdepends=('python-scipy: gel simulation'
+ 'python-matplotlib: gel simulation'
+ 'python-pyparsing: download'
+ 'python-requests: download'
+ 'python-cai2: express')
+source=("git+${url}.git?#tag=v${pkgver}")
+sha512sums=('SKIP')
build() {
- cd "$pkgname"
- python -m build --wheel --no-isolation
+ cd ${_base}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "$pkgname"
- PYTHONPATH=./src pytest -x --disable-warnings
+ cd ${_base}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
- export PYTHONHASHSEED=0
- cd "$pkgname"
- python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ cd ${_base}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}