summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2023-12-05 22:34:56 +0000
committerWill Handley2023-12-05 22:34:56 +0000
commitd336833db4f2731c99d7de72fd5d1e366ae86c1a (patch)
tree82c96221c6a8da39902bc7f0655316e8f8ce9353 /PKGBUILD
downloadaur-python-pyknos.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13dd75df7e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-pyknos
+_name=${pkgname#python-}
+pkgver=0.15.2
+pkgrel=1
+pkgdesc="conditional density estimation"
+arch=(any)
+url="https://github.com/mackelab/pyknos"
+license=(AGPL3)
+groups=()
+depends=(python-matplotlib python-numpy tensorboard python-pytorch python-tqdm python-nflows)
+makedepends=(python-build python-installer)
+provides=(lsbi)
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('ee09ea841858e79ed9f3e104b6654aea676f3403a2f228ef76151e108968caf3')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+