summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212024-04-09 09:45:20 +0200
committera8212024-04-09 09:45:20 +0200
commitb350249052c31c458cfc0ea2d56fa2b0026709cf (patch)
treec60c5332625dbec9f498fcfd2f3e95d9f6d53aff /PKGBUILD
parent2ba08d5bd7e8734d9b72fb9bb9a377d702fd8cef (diff)
downloadaur-python-rivescript.tar.gz
Version 1.15.0 - build tested only
* Update build to PEP 517 * Use git sources from tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd7b7bcba8d6..6ce72be80119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: Trevor <assviolat0r at live dot com>
+# Contributor: a821 at mail dot de
+# Contributor: Trevor <assviolat0r at live dot com>
pkgname=python-rivescript
-pkgver=1.8.1
+pkgver=1.15.0
pkgrel=1
pkgdesc="Rendering Intelligence Very Easily"
arch=('any')
license=('MIT')
-depends=('python2' 'python-six' 'python2-six' 'python-setuptools' 'python2-setuptools')
-conflicts=('python-rivescript-git')
-url=('https://pypi.python.org/pypi/rivescript')
-source=('https://pypi.python.org/packages/source/r/rivescript/rivescript-1.8.1.tar.gz')
-md5sums=('86cba9b7b1cf846d83d61f8ddeafa386')
-_distdir="rivescript-1.8.1"
+depends=('python-six')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+url="https://github.com/aichaos/rivescript-python"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('d148a9242ea88f2a5f3dd57a663a4ddd56729807ee24edcd37ade7ee690e1bfe')
-package() {
- cd "$srcdir/$_distdir"
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 || return 1
+build() {
+ cd rivescript-python-$pkgver
+ python -m build --wheel --no-isolation
}
-
-
-
+package() {
+ cd rivescript-python-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}