summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-28 12:35:51 +0300
committerCaleb Maclennan2024-04-28 12:35:51 +0300
commit9f37a5bb89dc956376ac78b2890c3ec9e18fa1e2 (patch)
treee8049c3c0cedb9e3dacdade0eb3eb087d6867d3c /PKGBUILD
parent3c6f333d351591454d2c1c5ff91cab7bb91a8ff4 (diff)
downloadaur-python-shortuuid.tar.gz
upgpkg: python-shortuuid 1.0.13-2
Rebuild for Python 3.12, cleanup packaging odds and ends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2895f633f642..f1a7933debc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
pkgname=python-shortuuid
_pkgname=${pkgname#python-}
pkgver=1.0.13
-pkgrel=1
+pkgrel=2
pkgdesc='library that generates concise, unambiguous, URL-safe UUIDs'
arch=(any)
url="https://github.com/skorokithakis/$_pkgname"
-license=(BSD)
+license=(BSD-3-Clause)
depends=(python)
options=(!emptydirs)
makedepends=(python-{build,installer,wheel}
python-poetry-core)
-checkdepends=(python-django)
+checkdepends=(python-django
+ python-pytest)
_archive="$_pkgname-$pkgver"
source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('2ac98d9ff16cac764d1f2e98cde146bce436714e6a6c74ec42c24a63c210ce1d')
@@ -26,7 +27,7 @@ build() {
check() {
cd "$_archive"
- python -m unittest discover
+ pytest
}
package() {