summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2895f633f642..f1a7933debc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
pkgname=python-shortuuid
_pkgname=${pkgname#python-}
pkgver=1.0.13
-pkgrel=1
+pkgrel=2
pkgdesc='library that generates concise, unambiguous, URL-safe UUIDs'
arch=(any)
url="https://github.com/skorokithakis/$_pkgname"
-license=(BSD)
+license=(BSD-3-Clause)
depends=(python)
options=(!emptydirs)
makedepends=(python-{build,installer,wheel}
python-poetry-core)
-checkdepends=(python-django)
+checkdepends=(python-django
+ python-pytest)
_archive="$_pkgname-$pkgver"
source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('2ac98d9ff16cac764d1f2e98cde146bce436714e6a6c74ec42c24a63c210ce1d')
@@ -26,7 +27,7 @@ build() {
check() {
cd "$_archive"
- python -m unittest discover
+ pytest
}
package() {